Apache Hive

  • 时间:
  • 浏览:3
  • 来源:大发快3官方网址—大发快3APP下载

1.Download hive-1.2.1 source code

5.Compile hive-1.2.1

Format: patch -p0|-p1 < xxxx.patch

不可能 使用参数-p0,就表示从当前目录,找一有一个多叫作b的目录,在它下面找一有一个多叫ql的目录,再在它下面找一有一个多叫src的目录。

其中.我歌词 尝试了以下 

hive-1.1.0-cdh5.8.0,

3.Patch HIVE-11920.1.patch

hive-2.0.0-apache,

Bug1:ADD JAR failing with URL schemes other than file/ivy/hdfs

https://issues.apache.org/jira/browse/HIVE-11920

:

7.Modify hive-site.xml

2.Download patch

不可能 使用参数-p1, 就表示忽略第一层,从当前目录找一有一个多叫ql的目录,在它下面找一有一个多叫src的目录。本来会忽略掉补丁头提到的b目录。

8.Rerun tar hive files

4.Download maven tool and configure parameter

不可能 后来使用CDH5.4.8,其Hive版本为1.1.0,其业务的脚本和jar也在此版本开发,全都有有全都有依赖性,兼容性等等。后来 我当.我歌词 计划将CDH5.4.8 Job迁移至AliYun EMR平台上,发现hive-1.1.0-cdh5.4.8与该平台的Apache Hadoop2.7.2 严重不也能兼容,于是花了很长时间在做这件事--根据业务脚本和jar包定制.我歌词 的hive-1.2.1-emr版本

6.Upload mysql-connector-java-5.1.36-bin.jar 

hive-1.1.0-cdh5.4.8等版本与Apache hadoop2.7.2与脚本内容兼容错误甚多,且尝试无法避免,于是选用hive-1.x.x系列的最新版。

hive-1.1.0-apache,